一、 问题原因

在新的办公环境 ubuntu16 上装了个 PyCharm ,正准备工作的时候,发现 PyCharm 上面有一个提示弹窗:
python 3.5 has reached its end-of-life dateand it is no longer supported in pycharm
虾米? PyCharm 不支持 python3.5 了吗?但 python3.5 好像是 ubuntu16 默认的 python3 版本了吧
经过查阅发现,截止于2021-06-25, PyCharm 支持的 python3 版本是 python3.6 ~ python3.10

二、 解决方法

通过源码方式安装最新稳定版 python ,截止于2021-06-25,最新稳定版为 python3.9.5
安装流程直通车 ↓

ubuntu16 通过源码方式安装 python3.9.5

参考文献

  1. pycharm的python版本问题
Logo

华为云1024程序员节送福利,参与活动赢单人4000元礼包,更有热门技术干货免费学习

更多推荐